using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img.*?src=[\'""](.*?)[\'""].*?>";
string input = @"<IMG SRC=""http://www.google.com/trans.gif"">
<A HREF=""http://www.google.com""><IMG SRC=""http://www.google.com/trans.gif""></A>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}