// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)<img.*?src=[\'"](.*?)[\'"].*?>"#).unwrap();
let string = "<IMG SRC=\"http://www.google.com/trans.gif\">
<A HREF=\"http://www.google.com\"><IMG SRC=\"http://www.google.com/trans.gif\"></A>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}