re = /<img.*?src=[\'"](.*?)[\'"].*?>/i
str = '<IMG SRC="http://www.google.com/trans.gif">
<A HREF="http://www.google.com"><IMG SRC="http://www.google.com/trans.gif"></A>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end