$re = '/<img.*?src=[\'"](.*?)[\'"].*?>/i';
$str = '<IMG SRC="http://www.google.com/trans.gif">
<A HREF="http://www.google.com"><IMG SRC="http://www.google.com/trans.gif"></A>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);