package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<img.*?src=[\'"](.*?)[\'"].*?>`)
var str = `<IMG SRC="http://www.google.com/trans.gif">
<A HREF="http://www.google.com"><IMG SRC="http://www.google.com/trans.gif"></A>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}