# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\b[0-9a-f]{8}\b-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-\b[0-9a-f]{12}\b)\s*\|\s*(.*?)\s*$/http:\/\/my-server\/media\/guid\/\1?v=$2/gm;t' <<< "35afe06d-8393-4559-b6d7-74d35ce131d8|Master
35afe06d-8393-4559-b6d7-74d35ce131d8| Master "