use strict;
my $str = '35afe06d-8393-4559-b6d7-74d35ce131d8|Master
35afe06d-8393-4559-b6d7-74d35ce131d8| Master ';
my $regex = qr/^(\b[0-9a-f]{8}\b-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-\b[0-9a-f]{12}\b)\s*\|\s*(.*?)\s*$/mp;
my $subst = 'http://my-server/media/guid/\\1?v=$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";