$re = '/^(\b[0-9a-f]{8}\b-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-\b[0-9a-f]{12}\b)\s*\|\s*(.*?)\s*$/m';
$str = '35afe06d-8393-4559-b6d7-74d35ce131d8|Master
35afe06d-8393-4559-b6d7-74d35ce131d8| Master ';
$subst = "http://my-server/media/guid/\1?v=$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;