#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\b[0-9a-f]{8}\b-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-\b[0-9a-f]{12}\b)\s*\|\s*(.*?)\s*$"
Local $sString = "35afe06d-8393-4559-b6d7-74d35ce131d8|Master" & @CRLF & _
"35afe06d-8393-4559-b6d7-74d35ce131d8| Master "
Local $sSubst = "http://my-server/media/guid/\1?v=$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)