import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\b[0-9a-f]{8}\\b-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-\\b[0-9a-f]{12}\\b)\\s*\\|\\s*(.*?)\\s*$";
final String string = "35afe06d-8393-4559-b6d7-74d35ce131d8|Master\n"
+ "35afe06d-8393-4559-b6d7-74d35ce131d8| Master ";
final String subst = "http://my-server/media/guid/\\1?v=$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}