# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\d{1,2})(\d{2})/$1:$2/gm;t' <<< "1430
1230a
1230am
430a"