#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\d{1,2})(\d{2})"
Local $sString = "1430" & @CRLF & _
"1230a" & @CRLF & _
"1230am" & @CRLF & _
"430a"
Local $sSubst = "$1:$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)