$re = '/^(\d{1,2})(\d{2})/m';
$str = '1430
1230a
1230am
430a';
$subst = "$1:$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;