use strict;
my $str = '1430
1230a
1230am
430a';
my $regex = qr/^(\d{1,2})(\d{2})/mp;
my $subst = '$1:$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";