#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[A-Z_]+$).*?_QPSK.*?_(SK)"
Local $sString = "FOO_QPSK_SK_BAR" & @CRLF & _
"FOO_QPSK_BLA_SK_BAR" & @CRLF & _
"" & @CRLF & _
"FOO_QPcSK_SK_BAR" & @CRLF & _
"FOO_RQPSK_BLA_SK_BAR"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")