import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[A-Z_]+$).*?_QPSK.*?_(SK)";
final String string = "FOO_QPSK_SK_BAR\n"
+ "FOO_QPSK_BLA_SK_BAR\n\n"
+ "FOO_QPcSK_SK_BAR\n"
+ "FOO_RQPSK_BLA_SK_BAR";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}