$re = '/^(?=[A-Z_]+$).*?_QPSK.*?_(SK)/m';
$str = 'FOO_QPSK_SK_BAR
FOO_QPSK_BLA_SK_BAR
FOO_QPcSK_SK_BAR
FOO_RQPSK_BLA_SK_BAR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);