re = /^(?=[A-Z_]+$).*?_QPSK.*?_(SK)/m
str = 'FOO_QPSK_SK_BAR
FOO_QPSK_BLA_SK_BAR
FOO_QPcSK_SK_BAR
FOO_RQPSK_BLA_SK_BAR'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end