#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "{{color}}"
Local $sString = "<script type="text/template" id="styleTemplate"> " & @CRLF & _
".item {" & @CRLF & _
" color: {{color}};" & @CRLF & _
" border-color:{{color}};" & @CRLF & _
"}" & @CRLF & _
"</script>"
Local $sSubst = "#000"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)