const regex = /{{color}}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{{color}}', 'g')
const str = `<script type="text/template" id="styleTemplate">
.item {
color: {{color}};
border-color:{{color}};
}
</script>`;
const subst = `#000`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);