$re = '/{{color}}/';
$str = '<script type="text/template" id="styleTemplate">
.item {
color: {{color}};
border-color:{{color}};
}
</script>';
$subst = "#000";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;