re = /{{color}}/
str = '<script type="text/template" id="styleTemplate">
.item {
color: {{color}};
border-color:{{color}};
}
</script>'
subst = '#000'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result