import re
regex = re.compile(r"{{color}}")
test_str = ("<script type=\"text/template\" id=\"styleTemplate\"> \n"
".item {\n"
" color: {{color}};\n"
" border-color:{{color}};\n"
"}\n"
"</script>")
subst = "#000"
result = regex.sub(subst, test_str)
if result:
print(result)