using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+(?:\s?\w+)?)((?:\s+[^\d]+)+)";
string input = @"2 eggs 24oz sweet potatoes 3 tbsp honey ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}