$re = '/(\d+(?:\s?\w+)?)((?:\s+[^\d]+)+)/';
$str = '2 eggs 24oz sweet potatoes 3 tbsp honey ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);