re = /(\d+(?:\s?\w+)?)((?:\s+[^\d]+)+)/
str = '2 eggs 24oz sweet potatoes 3 tbsp honey '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end