// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d+(?:\s?\w+)?)((?:\s+[^\d]+)+)").unwrap();
let string = "2 eggs 24oz sweet potatoes 3 tbsp honey ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}