package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+(?:\s?\w+)?)((?:\s+[^\d]+)+)`)
var str = `2 eggs 24oz sweet potatoes 3 tbsp honey `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}