#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-z0-9+.\-]*:)((\/\/)((([a-z]*\.)*)([a-z]+))(:[0-9]{1,5})?)?((\/(([a-zA-Z0-9\-_]*\.)*([a-zA-Z0-9\-_]+)|\.\.|\.)?)+)?((\?[a-zA-Z0-9]+=[a-zA-Z0-9]+)+)?$"
Local $sString = "https://example.org/absolute/URI/with/absolute/path/to/resource.txt" & @CRLF & _
"https://example.org/absolute/URI/with/absolute/path/to/resource" & @CRLF & _
"http://example.org/test.truc/lol_bob.vlc?good=true?awesome=verytrue" & @CRLF & _
"ftp://localhost:1337?acu=false?ing1=true" & @CRLF & _
"mftp://localhost" & @CRLF & _
"mftp://localhost:1337" & @CRLF & _
"mftp://localhost:1337/test.txt" & @CRLF & _
"mftp://localhost:1337/test" & @CRLF & _
"myscheme7:" & @CRLF & _
"file:/test/truc.txt" & @CRLF & _
"file:/../../test/./truc.txt" & @CRLF & _
"file:/././test/./truc.txt" & @CRLF & _
"file/././test/./truc.txt" & @CRLF & _
"/test.txt" & @CRLF & _
"http://hello.txt?why.not>nope" & @CRLF & _
"ftp://local:nope/test.txt/ah?good=false" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")