const regex = /^([a-z0-9+.\-]*:)((\/\/)((([a-z]*\.)*)([a-z]+))(:[0-9]{1,5})?)?((\/(([a-zA-Z0-9\-_]*\.)*([a-zA-Z0-9\-_]+)|\.\.|\.)?)+)?((\?[a-zA-Z0-9]+=[a-zA-Z0-9]+)+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-z0-9+.\\-]*:)((\\\/\\\/)((([a-z]*\\.)*)([a-z]+))(:[0-9]{1,5})?)?((\\\/(([a-zA-Z0-9\\-_]*\\.)*([a-zA-Z0-9\\-_]+)|\\.\\.|\\.)?)+)?((\\?[a-zA-Z0-9]+=[a-zA-Z0-9]+)+)?$', 'gm')
const str = `https://example.org/absolute/URI/with/absolute/path/to/resource.txt
https://example.org/absolute/URI/with/absolute/path/to/resource
http://example.org/test.truc/lol_bob.vlc?good=true?awesome=verytrue
ftp://localhost:1337?acu=false?ing1=true
mftp://localhost
mftp://localhost:1337
mftp://localhost:1337/test.txt
mftp://localhost:1337/test
myscheme7:
file:/test/truc.txt
file:/../../test/./truc.txt
file:/././test/./truc.txt
file/././test/./truc.txt
/test.txt
http://hello.txt?why.not>nope
ftp://local:nope/test.txt/ah?good=false
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}