import Foundation
let pattern = #"^([a-z0-9+.\-]*:)((\/\/)((([a-z]*\.)*)([a-z]+))(:[0-9]{1,5})?)?((\/(([a-zA-Z0-9\-_]*\.)*([a-zA-Z0-9\-_]+)|\.\.|\.)?)+)?((\?[a-zA-Z0-9]+=[a-zA-Z0-9]+)+)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://example.org/absolute/URI/with/absolute/path/to/resource.txt
https://example.org/absolute/URI/with/absolute/path/to/resource
http://example.org/test.truc/lol_bob.vlc?good=true?awesome=verytrue
ftp://localhost:1337?acu=false?ing1=true
mftp://localhost
mftp://localhost:1337
mftp://localhost:1337/test.txt
mftp://localhost:1337/test
myscheme7:
file:/test/truc.txt
file:/../../test/./truc.txt
file:/././test/./truc.txt
file/././test/./truc.txt
/test.txt
http://hello.txt?why.not>nope
ftp://local:nope/test.txt/ah?good=false
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)