$re = '/^([a-z0-9+.\-]*:)((\/\/)((([a-z]*\.)*)([a-z]+))(:[0-9]{1,5})?)?((\/(([a-zA-Z0-9\-_]*\.)*([a-zA-Z0-9\-_]+)|\.\.|\.)?)+)?((\?[a-zA-Z0-9]+=[a-zA-Z0-9]+)+)?$/m';
$str = 'https://example.org/absolute/URI/with/absolute/path/to/resource.txt
https://example.org/absolute/URI/with/absolute/path/to/resource
http://example.org/test.truc/lol_bob.vlc?good=true?awesome=verytrue
ftp://localhost:1337?acu=false?ing1=true
mftp://localhost
mftp://localhost:1337
mftp://localhost:1337/test.txt
mftp://localhost:1337/test
myscheme7:
file:/test/truc.txt
file:/../../test/./truc.txt
file:/././test/./truc.txt
file/././test/./truc.txt
/test.txt
http://hello.txt?why.not>nope
ftp://local:nope/test.txt/ah?good=false
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);