using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-z0-9+.\-]*:)((\/\/)((([a-z]*\.)*)([a-z]+))(:[0-9]{1,5})?)?((\/(([a-zA-Z0-9\-_]*\.)*([a-zA-Z0-9\-_]+)|\.\.|\.)?)+)?((\?[a-zA-Z0-9]+=[a-zA-Z0-9]+)+)?$";
string input = @"https://example.org/absolute/URI/with/absolute/path/to/resource.txt
https://example.org/absolute/URI/with/absolute/path/to/resource
http://example.org/test.truc/lol_bob.vlc?good=true?awesome=verytrue
ftp://localhost:1337?acu=false?ing1=true
mftp://localhost
mftp://localhost:1337
mftp://localhost:1337/test.txt
mftp://localhost:1337/test
myscheme7:
file:/test/truc.txt
file:/../../test/./truc.txt
file:/././test/./truc.txt
file/././test/./truc.txt
/test.txt
http://hello.txt?why.not>nope
ftp://local:nope/test.txt/ah?good=false
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}