#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/\*\*([^\/]*)\*\/"
Local $sString = "if ( empty( $data->random ) ) {" & @CRLF & _
" /**" & @CRLF & _
" * Brief description" & @CRLF & _
" *" & @CRLF & _
" * @since 1.0" & @CRLF & _
" * @param int $var Variable" & @CRLF & _
" */" & @CRLF & _
" do_function( 'identifier', $var );" & @CRLF & _
" /**" & @CRLF & _
" * Brief description" & @CRLF & _
" *" & @CRLF & _
" * @since 1.0" & @CRLF & _
" * @param int $var Variable" & @CRLF & _
" */" & @CRLF & _
" dont_function( 'identifier', $var );" & @CRLF & _
" exit;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"if ( empty( $data->random ) ) {" & @CRLF & _
" /**" & @CRLF & _
" * Brief description" & @CRLF & _
" *" & @CRLF & _
" * @since 1.0" & @CRLF & _
" * @param int $var Variable" & @CRLF & _
" */" & @CRLF & _
" hey_function( 'identifier', $var );" & @CRLF & _
" exit;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"if ( empty( $data->random ) ) {" & @CRLF & _
" /**" & @CRLF & _
" * Brief description" & @CRLF & _
" *" & @CRLF & _
" * @since 1.0" & @CRLF & _
" * @param int $var Variable" & @CRLF & _
" */" & @CRLF & _
" do_function( 'identifier', $var );" & @CRLF & _
" exit;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")