re = /\/\*\*([^\/]*)\*\//
str = 'if ( empty( $data->random ) ) {
/**
* Brief description
*
* @since 1.0
* @param int $var Variable
*/
do_function( \'identifier\', $var );
/**
* Brief description
*
* @since 1.0
* @param int $var Variable
*/
dont_function( \'identifier\', $var );
exit;
}
if ( empty( $data->random ) ) {
/**
* Brief description
*
* @since 1.0
* @param int $var Variable
*/
hey_function( \'identifier\', $var );
exit;
}
if ( empty( $data->random ) ) {
/**
* Brief description
*
* @since 1.0
* @param int $var Variable
*/
do_function( \'identifier\', $var );
exit;
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end