import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\*\\*([^\\/]*)\\*\\/";
final String string = "if ( empty( $data->random ) ) {\n"
+ " /**\n"
+ " * Brief description\n"
+ " *\n"
+ " * @since 1.0\n"
+ " * @param int $var Variable\n"
+ " */\n"
+ " do_function( 'identifier', $var );\n"
+ " /**\n"
+ " * Brief description\n"
+ " *\n"
+ " * @since 1.0\n"
+ " * @param int $var Variable\n"
+ " */\n"
+ " dont_function( 'identifier', $var );\n"
+ " exit;\n"
+ "}\n\n"
+ "if ( empty( $data->random ) ) {\n"
+ " /**\n"
+ " * Brief description\n"
+ " *\n"
+ " * @since 1.0\n"
+ " * @param int $var Variable\n"
+ " */\n"
+ " hey_function( 'identifier', $var );\n"
+ " exit;\n"
+ "}\n\n"
+ "if ( empty( $data->random ) ) {\n"
+ " /**\n"
+ " * Brief description\n"
+ " *\n"
+ " * @since 1.0\n"
+ " * @param int $var Variable\n"
+ " */\n"
+ " do_function( 'identifier', $var );\n"
+ " exit;\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}