const regex = /\/\*\*([^\/]*)\*\//g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/\\*\\*([^\\\/]*)\\*\\\/', 'g')
const str = `if ( empty( \$data->random ) ) {
/**
* Brief description
*
* @since 1.0
* @param int \$var Variable
*/
do_function( 'identifier', \$var );
/**
* Brief description
*
* @since 1.0
* @param int \$var Variable
*/
dont_function( 'identifier', \$var );
exit;
}
if ( empty( \$data->random ) ) {
/**
* Brief description
*
* @since 1.0
* @param int \$var Variable
*/
hey_function( 'identifier', \$var );
exit;
}
if ( empty( \$data->random ) ) {
/**
* Brief description
*
* @since 1.0
* @param int \$var Variable
*/
do_function( 'identifier', \$var );
exit;
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}