#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bwordA\s+((\w+\s+){3})wordX\b"
Local $sString = "wordA wordB wordC wordD wordX <= 3" & @CRLF & _
"wordA wordB wordC wordX <= 2" & @CRLF & _
"wordA wordB wordX <= 1" & @CRLF & _
"wordA wordX <= 0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")