$re = '/\bwordA\s+((\w+\s+){3})wordX\b/';
$str = 'wordA wordB wordC wordD wordX <= 3
wordA wordB wordC wordX <= 2
wordA wordB wordX <= 1
wordA wordX <= 0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);