const regex = /\bwordA\s+((\w+\s+){3})wordX\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bwordA\\s+((\\w+\\s+){3})wordX\\b', 'g')
const str = `wordA wordB wordC wordD wordX <= 3
wordA wordB wordC wordX <= 2
wordA wordB wordX <= 1
wordA wordX <= 0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}