import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bwordA\\s+((\\w+\\s+){3})wordX\\b";
final String string = "wordA wordB wordC wordD wordX <= 3\n"
+ "wordA wordB wordC wordX <= 2\n"
+ "wordA wordB wordX <= 1\n"
+ "wordA wordX <= 0";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}