re = /\bwordA\s+((\w+\s+){3})wordX\b/
str = 'wordA wordB wordC wordD wordX <= 3
wordA wordB wordC wordX <= 2
wordA wordB wordX <= 1
wordA wordX <= 0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end