#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(gclid|utm_[a-z]+)=[-_A-z0-9+()%.]+&?"
Local $sString = ""http://wearychef.com/chicken-spaghetti-casserole/?utm_source=MadMimi&utm_medium=email&utm_content=7+Easy+Dinner+Recipes+Featuring+Chicken+Spaghetti+Casserole+(PLUS+A+Call+For+Feedback)&utm_campaign=20150620_m126272097_06202015+chicken+spaghetti+and+menu+126&utm_term=Chicken+Spaghetti+Casserole""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")