// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(gclid|utm_[a-z]+)=[-_A-z0-9+()%.]+&?").unwrap();
let string = "\"http://wearychef.com/chicken-spaghetti-casserole/?utm_source=MadMimi&utm_medium=email&utm_content=7+Easy+Dinner+Recipes+Featuring+Chicken+Spaghetti+Casserole+(PLUS+A+Call+For+Feedback)&utm_campaign=20150620_m126272097_06202015+chicken+spaghetti+and+menu+126&utm_term=Chicken+Spaghetti+Casserole\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}