using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(gclid|utm_[a-z]+)=[-_A-z0-9+()%.]+&?";
string input = @"""http://wearychef.com/chicken-spaghetti-casserole/?utm_source=MadMimi&utm_medium=email&utm_content=7+Easy+Dinner+Recipes+Featuring+Chicken+Spaghetti+Casserole+(PLUS+A+Call+For+Feedback)&utm_campaign=20150620_m126272097_06202015+chicken+spaghetti+and+menu+126&utm_term=Chicken+Spaghetti+Casserole""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}