package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(gclid|utm_[a-z]+)=[-_A-z0-9+()%.]+&?`)
var str = `"http://wearychef.com/chicken-spaghetti-casserole/?utm_source=MadMimi&utm_medium=email&utm_content=7+Easy+Dinner+Recipes+Featuring+Chicken+Spaghetti+Casserole+(PLUS+A+Call+For+Feedback)&utm_campaign=20150620_m126272097_06202015+chicken+spaghetti+and+menu+126&utm_term=Chicken+Spaghetti+Casserole"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}