#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[wW][a-zA-Z0-9]*(\/[a-zA-Z0-9]+)*?\/\d+$"
Local $sString = "w1/2a/11" & @CRLF & _
"w1//01 " & @CRLF & _
"w1/2a/2" & @CRLF & _
"wa/sdf/21" & @CRLF & _
"w23a/we2/123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")