package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[wW][a-zA-Z0-9]*(\/[a-zA-Z0-9]+)*?\/\d+$`)
var str = `w1/2a/11
w1//01
w1/2a/2
wa/sdf/21
w23a/we2/123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}