use strict;
my $str = 'w1/2a/11
w1//01
w1/2a/2
wa/sdf/21
w23a/we2/123';
my $regex = qr~^[wW][a-zA-Z0-9]*(\/[a-zA-Z0-9]+)*?\/\d+$~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}