using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[wW][a-zA-Z0-9]*(\/[a-zA-Z0-9]+)*?\/\d+$";
string input = @"w1/2a/11
w1//01
w1/2a/2
wa/sdf/21
w23a/we2/123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}